Exchange 2013 – IMAP – Authentifizierungsfehler

Die letzten Tage verfolgte mich das Phänomen, dass auf einem meiner Exchange 2013 Server (Im Cluster) der IMAP-Zugang nicht mehr möglich war. Alle Dienste liefen, die IMAP Konfiguration war einwandfrei. Die Dienste und der Server wurden durchgestartet, ohne Erfolg.

 

Das entsprechende Imap-Test cmdlet brachte folgendes Resultat auf dem betroffenen Server

 

Test-ImapConnectivity -ClientAccessServer:betroffenerexchangeserver -MailboxCredential:(Get-Credential domain\testuser) | select -ExpandProperty Error

 

Microsoft.Exchange.Monitoring.ProtocolException: Authentifizierungsfehler. Die Verbindung wird geschlossen.
Von der Übertragungsverbindung können keine Daten gelesen werden:
Eine vorhandene Verbindung wurde vom Remotehost geschlossen. Serverantworten während des Herstellens der Verbindung: []. —> System.IO.IOException: Von der Übertragungsverbindung können keine Daten gelesen werden:
Eine vorhandene Verbindung wurde vom Remotehost geschlossen. —> System.Net.
Sockets.SocketException: Eine vorhandene Verbindung wurde vom Remotehost geschlossen

 

Wer ein englisches System betreibt, dürfte in etwa von folgender Meldung begrüßt werden

Microsoft.Exchange.Monitoring.ProtocolException: Authentication failed. The connection is being closed.
Unable to read data from the transport connection: An established connection was aborted by the software in your host machine.
Server response while making connection:[]. —> System.IO.IOException: Unable to read data from the transport connection:
An established connection was aborted by the software in your host machine. —> System.Net.Sockets.SocketException: An established connection was aborted by the software in your host machine

 

Wie sich nach zeitraubender Recherche herausgestellt hat, wurde die ImapProxy Komponente deaktiviert:

Get-ServerComponentState -Identity betroffenerserver

 

Nachdem der ImapProxy wieder mittels folgendem cmlets aktiviert wurde,

Set-ServerComponentState -Identity betroffenerserver -Component ImapProxy -Requester HealthAPI -State Active

 

war der IMAP-Zugriff wieder problemlos möglich. Der Proxy wurde ohne irgendwelche festzustellenden Fehler deaktiviert. Die Ursache dafür ist leider nach wie vor schleierhaft.

 

11 Kommentare

Kommentar hinterlassen

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.